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C H A P T E R  1 1

Ubuntu Replacements for 
Windows Programs

Ubuntu is a thoroughly modern operating system and, as such, includes a comprehen-

sive selection of software for just about every day-to-day task. Regardless of whether you 

want to write letters, edit images, or listen to music, Ubuntu offers something for you. 

This chapter introduces the software under Ubuntu that performs the tasks you might 

be used to under Windows. It’s not a detailed guide to each piece of software. Instead, this 

chapter aims to get you up and running with the Ubuntu replacement as quickly as possible. 

The chapter will tell you the name of the software, where you can find it on Ubuntu’s 

menus, and a few basic facts about how to use it. In many cases, these applications are 

covered in far more depth later in the book.

Available Software
Table 11-1 lists various popular Windows programs alongside their Ubuntu counterparts. 

You’ll find most of the programs listed on the Applications menu. Table 11-1 also includes 

a number of other mainstream alternatives, most of which aren’t installed by default 

under Ubuntu, but are available from the Ubuntu online software repositories. You might 

want to try these later on. As you might expect, they’re all free of charge, so you have 

nothing to lose.

■Note  Table 11-1 lists only a fraction of the programs available under Linux. There are quite literally thou-

sands of others. The programs listed here are those that work like their Windows equivalents and therefore 

provide an easy transition.
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Table 11-1. Ubuntu Alternatives to Windows Software

Type of Program Windows Ubuntu Alternative Choices

Word processor Microsoft Word OpenOffice.org 
Writer

AbiWord (www.abisource.com), 
KOffice KWord (www.koffice.org/
kword)

Spreadsheet Microsoft Excel OpenOffice.org 
Calc

Gnumeric (www.gnome.org/
projects/gnumeric), KOffice 
KSpread (www.koffice.org/
kspread)

Presentations Microsoft PowerPoint OpenOffice.org 
Impress

KOffice KPresenter 
(www.koffice.org/kpresenter)

Drawing 
(vector art)

Adobe Illustrator OpenOffice.org 
Draw

Inkscape (www.inkscape.org), 
KOffice Karbon 14 
(www.koffice.org/karbon)

Database Microsoft Access OpenOffice.org 
Base1

Knoda (www.knoda.org)

Web page creation Microsoft FrontPage OpenOffice.org 
Writer

SeaMonkey (www.mozilla.org/
projects/seamonkey), Amaya 
(www.w3.org/Amaya)

E-mail Microsoft Outlook Evolution Mozilla Thunderbird 
(www.mozilla.com), KMail (http://
kontact.kde.org/kmail) 

Contacts manager/ 
calendar

Microsoft Outlook Evolution Kontact (www.kontact.kde.org)

Web browser Microsoft Internet 
Explorer

Mozilla Firefox Konqueror (www.konqueror.org), 
Opera (www.opera.com)2

CD/DVD burning Nero Nautilus3 K3b (www.k3b.org), Brasero 
(www.gnome.org/projects/
brasero)

MP3 player Winamp Rhythmbox Aqualung (http://
aqualung.factorial.hu), Banshee 
(http://banshee-project.org)

CD player/ripper Windows Media Player  Sound Juicer Grip (http://nostatic.org/grip)

Movie/DVD player Windows Media Player Totem Media 
Player

VLC (www.videolan.org) MPlayer 
(www.mplayerhq.hu/homepage)

Image editor Adobe Photoshop The GIMP KOffice Krita (www.koffice.org/
krita)

Zip files WinZip Archive Manager KArchiver (http://pagesperso-
orange.fr/coquelle/karchiver)

MS-DOS prompt cmd.exe/command.exe GNOME 
Terminal

Xterm (www.x.org)4

Calculator Calc Calculator Too many to mention!
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1 Base isn’t installed by default, but it is easily installed via the openoffice.org-base package. This database 

tool is tightly integrated with the rest of the OpenOffice.org suite.

2 Opera is a proprietary product, rather than open source; however, it is free of charge.

3 Nautilus is the file manager within Ubuntu; to activate its CD/DVD burning mode, click Go ➤ CD/DVD 
Creator.

4 Xterm is part of the X.org package, so it is installed by default under Ubuntu. To use it, type xterm in a 
GNOME Terminal window. See Chapter 10 to learn how to create a permanent desktop launcher for Xterm.

LINUX HAS IT ALL

The Ubuntu software archives contain thousands of programs to cover just about every task you might 

wish to do on your computer. Diversity is vitally important within the Linux world. For example, rather 

than offering just one e-mail program, you’ll find many available. They compete with each other in a 

gentle way, and it’s up to you which one you settle down with and use.

Part of the fun of using Linux is exploring what’s available. Of course, the added bonus is that virtu-

ally all this software is free of charge, so you can simply download, install, and play around. If you don’t 

like a program, just remove it from your system. However, don’t forget to revisit the program’s home 

page after a few months; chances are the program will have been expanded and improved in that short 

period, and it might be better at meeting your needs.

A Quick Start with Common Linux Programs
The remainder of this chapter outlines a handful of the programs listed in Table 11-1. Our 

goal is to give you a head start in using each program, pointing out where most of the main 

functions can be found. You’ll find more details about the The GIMP image editor, multi-

media tools, and office applications in Parts 5 and 6 of this book.

Keep in mind that Linux doesn’t aim to be an exact clone of other operating systems. 

Some of the programs will work in a similar way to what you’re used to, but that’s not true 

of all of them. Because of this, it’s very easy to get frustrated early on when programs don’t 

seem to work quite how you want or respond in strange ways. Some programs might hide 

functions in what seem like illogical places compared with their counterparts on other 

operating systems. Some patience is required, but it will eventually pay off as you get used 

to Linux.

Text editor/viewer Notepad Gedit Kate (www.kate-editor.org)

Desktop games Minesweeper/Solitaire Mines/AisleRiot 
Solitaire 

Too many to mention!

Table 11-1. Ubuntu Alternatives to Windows Software (Continued)

Type of Program Windows Ubuntu Alternative Choices
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Word Processing: OpenOffice.org Writer

OpenOffice.org is an entire office suite for Linux that was built from the ground up to 

compete with Microsoft Office. Because of this, you’ll find much of the functionality of 

Microsoft Office is replicated in OpenOffice.org, and the look and feel are also similar. The 

major difference is that OpenOffice.org is open source and therefore free of charge. 

OpenOffice.org Writer (Applications ➤ Office ➤ OpenOffice.org Word Processor), 

shown in Figure 11-1, is the word processor component. As with Microsoft Word, it’s fully 

WYSIWYG (What You See Is What You Get), so you can quickly format text and paragraphs. 

This means the program can be used for elementary desktop publishing, and pictures can 

be easily inserted (using the Insert menu).

Figure 11-1. OpenOffice.org Writer

Writer’s toolbars provide quick access to the formatting tools, as well as to other common 

functions. The vast majority of menu options match those found in Word. Right-clicking 

the text itself also offers quick access to text-formatting tools. 

A number of higher-level functions are provided, such as mail merge and spell-checking, 

(found on the Tools menu). You can perform spell-checking on the fly, with incorrect 

words underlined in red as you type.
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As with all OpenOffice.org packages, Writer is fully compatible with Microsoft Office 

files, so you can save and open .doc files. Just click File ➤ Save As, and click the arrow 

alongside File Type to choose a document format. The only exception is password-

protected Word files, which cannot be opened. You can also export documents as PDF 

files (using File ➤ Export As PDF), so they can be read on any computer that has Adobe 

Acrobat Reader installed.

■Note   Although compatible with Microsoft Office 2003 (and below) file formats, OpenOffice.org isn’t 

compatible with Office 2007’s Open XML file format at the time of writing. However, this will almost certainly 

change, which is another reason to regularly update your Ubuntu system.

OpenOffice.org Writer is covered in more detail in Chapter 23.

Spreadsheet: OpenOffice.org Calc

As with most of the packages that form the OpenOffice.org suite, Calc (Applications ➤ 

Office ➤ OpenOffice.org Spreadsheet) does a good impersonation of its proprietary coun-

terpart, Microsoft Excel, both in terms of powerful features and the look and feel, as you 

can see in Figure 11-2. However, it has only limited support for Excel’s Visual Basic for 

Applications (VBA) macros at present. Instead, Calc and other OpenOffice.org programs 

use their own macro language, called OpenOffice.org Basic (for more information, see 

http://development.openoffice.org).

Calc has a vast number of mathematical functions. To see a list, choose Insert ➤ Function. 

The list on the left side of the dialog box includes a brief explanation of each function to 

help you get started. Just as with Excel, you can access the functions via the toolbar (by 

clicking the Function Wizard button), or you can enter them directly into cells by typing 

an equal sign and then the formula code. Calc is intelligent enough to realize when formula 

cells have been moved and to recalculate accordingly. It will even attempt to calculate 

formulas automatically and can work out what you mean if you type something like sales 

+ expenses as a formula.

As you would expect, Calc also provides automated charting and graphing tools (under 

Insert ➤ Chart). In Figure 11-2, you can see an example of a simple chart created automat-

ically by the charting tool.

You can format cells using the main toolbar buttons, or automatically apply user-defined 

styles (choose Format ➤ Styles and Formatting). 
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■Tip  In all the OpenOffice.org applications, you can hover the mouse cursor over each button for one 

second to see a tooltip showing what it does.

Figure 11-2. OpenOffice.org Calc

If you’re a business user, you’ll be pleased to hear that you can import databases to 

perform serious number-crunching. Use Insert ➤ Link to External Data to get the data, 

and then employ the tools on the Data and Tools menu to manipulate it.

As with all OpenOffice.org programs, compatibility with its Microsoft counterpart—

Excel files in this case—is pretty good. You can also open other common data file formats, 

such as comma-separated values (CSV) and Lotus 1-2-3 files.

OpenOffice.org Calc is covered in more detail in Chapter 24. 
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Presentations: OpenOffice.org Impress

Anyone who has used PowerPoint will immediately feel at home with Impress, 

OpenOffice.org’s presentation package (Applications ➤ Office ➤ OpenOffice.org 

Presentation), shown in Figure 11-3. Impress duplicates most of the common features 

found in PowerPoint, with a helping of OpenOffice.org-specific extras.

The program works via templates into which you enter your data. Starting the program 

causes the Presentation Wizard to appear. This wizard guides you through selecting a 

style of presentation fitting the job you have in mind. At this point, you can even select the 

type of transition effects you want between the various slides.

Once the wizard has finished, you can choose from the usual normal and outline view 

modes (available from the View menu). Outline mode lets you enter your thoughts quickly, 

while normal mode lets you type straight onto presentation slides. 

You can format text by highlighting it and right-clicking it, by using the Text Formatting 

toolbar that appears whenever you click inside a text box, or by selecting an entry on the 

Format menu. Impress also features a healthy selection of drawing tools, so you can create 

quite complex diagrams. These are available on the Drawing toolbar along the bottom of 

the screen. You can also easily insert pictures, other graphics, and sound effects.

Figure 11-3. OpenOffice.org Impress
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You can open and edit existing PowerPoint (PPT) files and, as with all OpenOffice.org 

packages, save your presentation as a PDF file. Impress also lets you export your presentation 

as a Macromedia Flash file (SWF). This means that anyone with a browser and Macromedia’s 

Flash plug-in can view the file, either online or via e-mail. Simply click File ➤ Export, and 

then choose Macromedia Flash from the File Format drop-down list.

Along with slide presentations, Impress also lets you produce handouts to support 

your work.

OpenOffice.org Impress is covered in more detail in Chapter 25.

Database: OpenOffice.org Base

Base, shown in Figure 11-4, allows you to create relational databases using a built-in data-

base engine, as well as interface with external databases. Base is not installed by default, 

so you will need to install the openoffice.org-base package using System ➤ Administra-

tion ➤ Synaptic Package Manager. Then you can access it by clicking Applications ➤ 

Office ➤ OpenOffice.org Database. 

Base is very similar to Microsoft Access in look and feel, although it lacks some of 

Access’s high-end functions. For most database uses, it should prove perfectly adequate.

If you know the fundamentals of database technology, you shouldn’t have any trouble 

getting started with Base immediately. This is made even easier than you might expect, 

because when the program starts, a wizard guides you through the creation of a simple 

database. 

As with Access, Base is designed on the principles of tables of data, forms by which the 

data is input or accessed, and queries and reports by which the data can be examined and 

outputted. Once again, wizards are available to walk you through the creation of each of 

these, or you can dive straight in and edit each by hand, by selecting the relevant option.

Each field in the table can be of various types, including several different integer and 

text types, as well as binary and Boolean values. Forms can contain a variety of controls, 

ranging from simple text boxes to radio buttons and scrolling lists, all of which can make 

data entry easier. Reports can feature a variety of text formatting and can also rely on 

queries to manipulate the data. The queries themselves can feature a variety of functions 

and filters in order to sort data down to the finest detail. 

You’ll learn more about Base in Chapter 26.
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Figure 11-4. OpenOffice.org Base

E-Mail/Personal Information Manager: Evolution

Evolution is a little like Microsoft Outlook in that, in addition to being an e-mail client, it 

can also keep track of your appointments and contacts. You can start Evolution by clicking 

Applications ➤ Office ➤ Evolution Mail and Calendar.

Before using the program, you’ll need to set it up with your mail server settings, as 

detailed in Chapter 8. Evolution is compatible with POP/SMTP, IMAP, Novell GroupWise, 

Hula, Microsoft Exchange, and a handful of Unix mail formats rarely used nowadays. 

Once the program is up and running, as shown in Figure 11-5, you can create a new 

message by clicking the New button on the toolbar. To reply to any e-mail, simply select it 

in the list, and then click the Reply or Reply To All button, depending on whether you want 

to reply to the sender or to all the recipients of the message.
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To switch to Contacts view, click the relevant button on the bottom left. If you reply 

to anyone via e-mail, they’re automatically added to this Contacts list. You can also add 

entries manually by either right-clicking someone’s address in an open e-mail or right- 

clicking in a blank space in the Contacts view.

Clicking the Calendar view shows a day-and-month diary. To add an appointment, 

simply select the day, and then double-click the time you want the appointment to start. 

You can opt to set an alarm when creating the appointment, so that you’re reminded of it 

when it’s scheduled.

Finally, by clicking the Tasks and Memos buttons, you can create a to-do list and jot 

down quick notes, respectively. To add a task, click the bar at the top of the list. Once an 

entry has been created, you can put a check in its box to mark it as completed. Completed 

tasks are marked with strike-through, so you can see at a glance what you still need to do. 

To add a memo, click the bar at the top of the memo list, and simply type what you want 

to remember.

In addition to the setup guide in Chapter 8, you’ll find a full explanation of Evolution’s 

features in Chapter 27.

Figure 11-5. Evolution

Web Browser: Firefox

You might already know of Mozilla Firefox under Windows, where it has firmly established 

itself as the alternative browser of choice. The good news is that the Linux version of 

Firefox is nearly identical to its Windows counterpart. Start it by selecting Applications ➤ 

Internet ➤ Firefox Web Browser.
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When the program starts, as shown in Figure 11-6, you can type an address into the 

URL bar to visit a web site. If you wish to add a site to your bookmarks list, click Bookmarks ➤ 

Bookmark This Page. Alternatively, you can press Ctrl+D. 

Searching is very easy within Firefox, using its search bar at the top right of the window. 

By default, Firefox uses Google for searches. To choose from other search engines, click 

the small down arrow on the left side of the search box. You can even enter your own 

choice of site if your favorite isn’t already in the list—click Manage Search Engines, and 

then click the Get More Search Engines link in the dialog box that appears. 

Firefox popularized the principle of tabbed browsing, which means you can have more 

than one site open at once. To open a new tab, press Ctrl+T. You can move between the 

tabs by clicking them. 

Figure 11-6. Mozilla Firefox

■Tip  When Firefox starts, tabs aren’t activated. If you would like to keep tabs in view all the time, click 

Edit ➤ Preferences, and then click the Tabs button. Then put a check alongside Always Show the Tab Bar.

Firefox is compatible with most of the same add-ons (extensions) you might have used 

under the Windows version of the browser. You can download new add-ons from https://

addons.mozilla.org. In addition, Firefox under Ubuntu can work with Flash animations, 
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although you’ll need to download the Flash Player software first. See the instructions in 

Chapter 19 to learn more. 

Audio Playback: Rhythmbox and Sound Juicer

Ubuntu’s multimedia software is basic but effective. It can play back the majority of audio 

files, as long as it’s properly configured, which is to say after additional software has been 

installed. We’ll describe how to set up this software in Chapter 18, and if you’re thinking 

of playing audio files on your computer, you may want to read that chapter immediately. 

Rhythmbox is the audio file player, which can be started by clicking Applications ➤ 

Sound & Video ➤ Rhythmbox Music Player. Sound Juicer is primarily designed to rip CD 

tracks to disk, but it also serves as Ubuntu’s CD player (simply click the Play button in the 

program window to listen to tracks). Figure 11-7 shows both of these applications.

Figure 11-7. Rhythmbox and Sound Juicer

When you run Rhythmbox for the first time, it will attempt to find and then catalog 

your music collection. You might be used to this kind of functionality with Windows 

applications like iTunes. After the initial file search has taken place, whenever Rhythmbox 

runs, you will find your tracks listed by artist or name, providing they have the relevant tag 

information embedded in them (such as ID3 tags in MP3 music).
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■Note  Unlike iTunes, Rhythmbox can’t play Digital Rights Management (DRM)-protected files. 

To start playing a music track, double-click it in the list. To make the player smaller so 

that it doesn’t dominate the screen, click View ➤ Small Display.

Sound Juicer is very simple to operate. It will open automatically once a CD has been 

inserted. To start playing the CD, select a track from the list and click the Play button, just 

click Play to play the CD starting from track 1. While Sound Juicer is playing, you can 

switch to any other tracks by double-clicking them in the list. One nice feature of Sound 

Juicer is that it will automatically look up the artist and track information about most CDs 

online, and then save the information for future reference. 

You can control the volume within Rhythmbox or Sound Juicer, or use the volume 

control applet, which is located at the top-right side of the Ubuntu desktop, near the 

clock. Simply click and then drag the slider to adjust the volume.

Movie Playback: Totem Movie Player

Totem Movie Player, which can be started by clicking Applications ➤ Sound & Video ➤ 

Movie Player, is able to handle the majority of video files you might own, as long as some 

additional software is installed. Totem can also play back DVD movies, which, again, 

requires the installation of software. We’ll cover setting up this software in Chapters 18 

and 19; if you intend to play back videos and DVDs, these chapters should be your first 

port of call.

Like Rhythmbox and Sound Juicer, Totem is an uncomplicated application. As shown 

in Figure 11-8, the video will play on the left side of the window. A playlist detailing movies 

you have queued appears on the right side. You can remove this, to give the video more 

room, by clicking the Sidebar button.

You can control video playback using the play/pause, fast forward, and rewind buttons 

at the bottom left. In addition, provided a compatible video format is being played, you 

can use the Time bar to move backward and forward within the video file. You can switch 

to full-screen playback by clicking View ➤ Fullscreen. To switch back, simply press the 

Esc key. If you’re watching a program that has been ripped from TV, you might want to 

use the Deinterlace feature on the View menu to remove any interference patterns. 

Provided the software described in Chapter 19 is installed, DVD playback will start 

automatically as soon as a disc is inserted, and you should be able to use the mouse with 

any on-screen menus. In addition, you can skip between chapters on the disc using the 

Go menu, and also return to the DVD’s main or submenu systems. To switch between the 

various languages on a DVD (if applicable), click Sound ➤ Languages and choose from 

the list.
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Figure 11-8. Totem Movie Player

CD/DVD Burning: Nautilus and Brasero

As soon as you insert a blank writable disc, whether it’s a CD or DVD, Ubuntu will detect 

it and offer you two choices. You can then create a data or audio disc. If you choose to 

create an audio CD, the Brasero application will open. If you choose to create a data or 

photo CD/DVD, a Nautilus file browser window will open in CD/DVD Creator mode. Both 

programs are shown in Figure 11-9.

To use Brasero to create an audio CD, drag-and-drop your music files onto the program 

window, and then click the Burn button. Keep an eye on the meter at the bottom right. 

This is like a progress bar; when the green portion is full, the disc is full. Note that you 

won’t be able to write certain audio files, like MP3s, to CDs unless you have the relevant 

codecs installed. See Chapter 18 to learn more.

Using the Nautilus CD/DVD Creator is similar to using Brasero. Just drag-and-drop 

files onto the window to create shortcuts to the files. When it comes time to burn, Nautilus 

will copy the files from their original locations. When you’ve finished choosing files, click 

the Write to Disc button. Unfortunately, you won’t see a warning if the disc’s capacity has 

been exceeded until you try to write to the disc. However, by right-clicking an empty space 

in the Nautilus window and selecting Properties, you can discover the total size of the 

files. Remember that most CDs hold 700MB, and most DVD+/-R discs hold around 4.7GB 

(some dual-layer discs hold twice this amount; see the DVD disc packaging for details).
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■Tip  Most modern CD/DVD recorders utilize burn-proof technology, which helps ensure error-free disc 

creation. To activate this, open a terminal window (Applications ➤ Accessories ➤ Terminal), and type 

gconf-editor. When the program starts, click Edit ➤ Find, and then type burnproof. Make sure there’s 

a check in Search Also in Key Names. In the search results at the bottom of the window, click the first result 

(/apps/nautilus-cd-burner/burnproof) and make sure there’s a check in burnproof at the top right 

of the window. Then close the configuration editor. 

Figure 11-9. Nautilus CD/DVD Creator and Brasero

Photo Editing: The GIMP

While many of the other programs introduced so far mirror the Windows look and feel in 

some way, The GIMP walks a different path. It has its own unique way of working, which 

takes a little getting used to. But it’s very much worth the effort, because The GIMP offers 

photo-editing tools on par with professional products like Adobe Photoshop. It’s certainly 

more than powerful enough for tweaking digital camera snapshots.

To start The GIMP, select Applications ➤ Graphics ➤ GNU Image Manipulation Program. 

Once the program is running, you’ll notice that it’s actually little more than a large toolbar 

on the left side of the screen. Everything else that runs within The GIMP—whether it’s a 
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window containing the image you’re editing or an additional configuration dialog box—

uses its own program window. This also means that each program item that you activate 

gets its own button on the panel at the bottom of the screen.

To open a picture, select File ➤ Open and select your image from the hard disk. Once 

an image file is opened, you can manipulate it using the tools on the toolbar (which are 

similar to those found in other image editors). On the bottom half of the main program 

window, you’ll find the settings for each tool, which can be altered, usually via click-and- 

drag sliders.

To apply filters or other corrective changes, right-click anywhere on the image to bring 

up a context menu with a variety of options. For example, simple tools to improve bright-

ness and contrast can be found on the Colors submenu, as shown in Figure 11-10.

For an in-depth look at The GIMP package, see Chapter 20.

Figure 11-10. The GIMP
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Other Handy Applications

Many additional applications might prove useful on a day-to-day basis. Here, we’ll review 

some of the more common ones. 

Calculator

The GNOME Calculator (also known as Gcalctool) can be found on the Applications ➤ 

Accessories menu. In its default mode, shown in Figure 11-11, it shouldn’t present any 

challenges to anyone who has ever used a real-life calculator, although the Bksp key might 

be new. This simply deletes the last number you typed (handy if you miskey during a 

calculation).

Figure 11-11. GNOME Calculator

Calculator also has three other modes that you can switch into using the View menu: 

Advanced, Financial, and Scientific. All offer calculator functions relevant to their settings. 

The Advanced mode is simply a more complicated version of the basic Calculator. It can 

store numbers in several memory locations, for example, and can also carry out less common 

calculations, such as square roots and reciprocals.

Archive Manager

Archive Manager (also known as File Roller), shown in Figure 11-12, is Ubuntu’s archive 

tool. It’s the default program that opens whenever you double-click .zip files (or .tar, 

.gz, or .bzip2 files, which are the native archive file formats under Linux). 

To extract files from an archive, select them (hold down the Ctrl key to select more than 

one file), and then click the Extract button on the toolbar.
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To create an archive on the fly, select files or folders in a Nautilus file browser window, 

right-click the selection, and select Create Archive. Give the archive a name, and the 

archive will be created. To add new files to an existing archive, double-click an archive file, 

and then drag-and-drop files into the Archive Manager window. When you’ve finished, 

simply close the Archive Manager window.

Figure 11-12. Archive Manager

Dictionary

You can use the Dictionary tool to look up the definitions of words using the Collaborative 

International Dictionary of English. This dictionary is based on a 1913 edition of Webster’s 

Revised Unabridged Dictionary, but with some additional modern definitions. The Dictio-

nary tool is useful for quick lookups, although if you want a precise and modern definition 

of a word, you might consider using a more contemporary source.
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You’ll find the Dictionary program on the Applications ➤ Accessories menu. Type the 

word in the Look Up text box at the top of the window, and its definition will appear in the 

area below, as shown in Figure 11-13. As soon as you start typing, the program will begin 

to look up the word in the dictionary, and this can cause a momentary delay before the 

letters appear on your screen.

Figure 11-13. Dictionary

Pidgin Internet Messenger

Pidgin is the instant messaging software provided with Ubuntu. Unlike most other messaging 

programs, Pidgin isn’t exclusive to one chat protocol. You can use it to connect to MSN, 

AOL/ICQ, Yahoo!, and many other services. The program can be found on the Applica-

tions ➤ Internet menu.

Details for setting up Pidgin are in Chapter 8. Once the program is up and running, you 

can chat with any of your buddies by double-clicking their icon, as shown in Figure 11-14.

The rest of the program can be administered by right-clicking the notification area icon 

that appears when the program starts. For example, you can change your status or sign off 

from there.
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Figure 11-14. Pidgin

Mines

Mines is the Ubuntu equivalent of Minesweeper, and is almost exactly the same as the 

Windows program, as you can see in Figure 11-15. The rules are identical, too: on each 

grid are several hidden mines, and it’s your job to locate them. After you’ve clicked one 

square at random, you’ll see a series of empty squares and several with numbers in them. 

Those with numbers indicate that a bomb is near. Your job is to deduce where the bombs 

are, and then mark them by right-clicking them. You have to do this as quickly as possible, 

because you’re being timed.

To change the grid size, click Settings ➤ Preferences. Your choices are Small, Medium, 

Large, and Custom.
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Figure 11-15. Mines

Ekiga

Ekiga provides Internet telephony (known as Voice over IP, or VoIP), via the SIP and H.323 

protocols. It also provides video conferencing, and is compatible with all major features 

specified within SIP and H.323, such as holding, forwarding, and transferring calls. Ekiga 

can be found on the Applications ➤ Internet menu.

To activate the camera mode for a video conference, click the webcam icon on the left 

side of the window. To text chat, click the top icon on the left side of the window.

When the program starts, it will walk you through setup via a wizard. Simply answer the 

questions with your details. Once the program is up and running, as shown in Figure 11-16, 

type the URL of the person you would like to call into the address bar and click Call ➤ Call.

Note that Ekiga is not compatible with proprietary VoIP software, such as Skype. To 

learn how to install Skype under Ubuntu, see Chapter 18.



278 CH AP T E R  1 1  ■  U B U N TU  R E PL A CE M E N T S  F O R  W IN DO W S PR O G R A M S

Figure 11-16. Ekiga

Summary
In this chapter, we’ve taken a look at some Ubuntu programs that provide vital functions 

that you might have used daily under Windows. The aim was to get you started with this 

software as quickly as possible by pointing out key features. You’ve seen how some programs 

mirror the look and feel of their Windows counterparts almost to the letter, while others 

resolutely strike out on their own path. It takes just a little time to become familiar with 

Ubuntu software, and then using these programs will become second nature.

In the next chapter, we’ll move on to more fundamental Ubuntu tasks: manipulating 

files. However, once again, this is not too dissimilar from the Windows experience, which 

makes getting used to the system very easy.


